artykuły

[JavaScript/jQuery] Plugin jQuery.jqtransform przestał działać po aktualizacji jQuery

18:38
pią, 4 lipiec 2014
Winne temu jest wycofanie przez jQuery funkcji jQuery.browser, za pomocą której plugin jqtransform wykrywał, że ma do czynienia z przeglądarką Safari. Niestety, od wersji 1.8 biblioteki jQuery, funkcja jQuery.browser została wycofana. Jednak błąd można łatwo naprawić, zerkając do źródła pluginu jqtransform i zamieniajac wszystkie wystąpienia $.browser na (navigator.userAgent.toLowerCase().indexOf('safari/') > -1). To wszystko. Od tego momentu wszystko powinno już działać.

Podobne faq:

Skomentuj

Aby zamieścić komentarz, proszę włączyć JavaScript - niestety roboty spamujące dają mi niezmiernie popalić.






Komentarze czytelników

    Nie ma jeszcze żadnych komentarzy.
    Dexter