artykuły

Brak Połaczenia z serwerem

2008-03-25
17:05:00
Avatar
bartek89
Data publikacji:
18:05, 25 marzec 2008
Witam Mam następujący problem a mianowicie gdy tworze aplikacje klienta i serwera i probuje połączyć sie z serwerem z drugiego komputera pojawia sie ład "Socker Error # 10060." wszystko jest raczej skonfigurowane poprawnie i nic nie idzie niestety
Avatar
Lukas
Strona domowa
Data publikacji:
10:02, 26 marzec 2008
10060 to błąd upłycięcia limitu czasu ( [url=http://msdn2.microsoft.com/en-us/library/ms740668(VS.85).aspx http://msdn2.microsoft.com/en-us/library/ms740668(VS.85).aspx[/url] ).
10060: A connection attempt failed because the connected party did not properly respond after a period of time, or the established connection failed because the connected host has failed to respond.
Trudno jest cokolwiek powiedzieć na odległość poza powyższym. Ja zawsze sprawdzam takie błędy snifferem (polecam [url=http://erwan.l.free.fr/sniffer.zip]IP Sniffer[/url]). Pozwala on założyć filtr na dany port i sprawdzić przebieg całej komunikacji w najdrobniejszych szczegółach. Jest dość łatwy w obsłudze (ale i trochę toporny - czasami nie pamięta poprzednich ustawień ;). Obsługa: - włączasz - wybierasz interfejs sieciowy (twoją kartę sieciową przez którą odbywa się komunikacja) - zakładasz filtr na port którym posługują się Twoje programy (ikonka z lupą). - klikasz przycisk z zieloną strzałką - uruchamiasz pogramy i rozpoczynasz komunikację (sniffer na zielono zaznacza pakiety przychodzące do Ciebie, na czerwono zaś wychodzące od Ciebie) - zakańczasz sniffing przyciskiem z bordowym kwadratem i czytasz szczegóły po których powinienneś rozpoznać poszczególne pakiety (szczegóły dostepne są dopiero po zatrzymaniu sniffingu) Jeśli Ci to nie pomoże, możesz podesłać mi te aplikacje - sprawdze co z nimi nie tak...




Zaloguj się aby dodać post.
Dexter